Aquellos que tienen algo que enseñar buscan desesperadamente alumnos que quieran aprender, pero es como encontrar una aguja en un pajar.
El Mentor Hacker, Manifiesto Hacker
USUARIO & PREFERENCIAS

18 de Enero, 2018, 04:56:33

Noticias: Bienvenidos. Arwinianos ahora es Xarw. Como podrán ver, el nombre deriva de ex-arwinianos.


FORO
+  .:: Xarw.Net ::.
|-+  Foros
| |-+  Software
| | |-+  Problema para instalar archivos .msi
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Problema para instalar archivos .msi  (Leído 23010 veces)
Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Problema para instalar archivos .msi
« en: 16 de Enero, 2010, 00:07:42 »

Hola mis muy estimados amigos arwinianos... Bueno, pues qué les cuento. Que estoy haciendo uso de este espacio para pedirles sus opiniones. Sólo me he permitido esto hasta que agote todos los recursos conocidos por mi para solucionar mi problema.... Pero como no lo he podido solucionar, pues aquí estoy dando lata. Así que como dice el Dr. House: necesito diagnóstico diferencial.

El problema es el siguiente:

No sé bien si todo comenzó desde que compre mi lap, o desde que hice alguna limpieza de bichos en la compu o desde que borre un programa (si no mal recuerdo, el FIFA 2008), pero el caso es que no he logrado instalar programas ejecutables de formato ".msi". Aun cuando estos sean compatibles con Windows Vista.


Qué he hecho hasta ahora?

-He actualizado Windows
-He analizado el sistema cientos de veces con varios antivirus (instalados y online) para ver si el problema es algún virus.
-He pasado el Hijack pa ver si existe algo raro
-He intentado instalar versiones anteriores de Windows Installer
-He actualizado mi Windows Installer a la versión 4.5 que se supone es la más reciente y que te permite instalar archivos .msi
-He desfragmentado el disco
-He realizado un ScanDisk

Pero, pues como suponen, el problema no se resolvió y por ello estoy aquí...

¿Alguna idea equipo?.... Vamos muchachos... por lo menos algo porque ya me quebré la cabeza y no consigo dar con la solución... Y claro, la verdad estoy un poco renuente y no quiero reinstalar el SO o cambiarlo... (en alguna ocasión ya lo había sugerido me parece que Nekro)... y por supuesto, no quiero formatear la compu....

Ello en razón de que tengo varios programas instalados que me daría muxa flojera volver a reinstalar (entre ellos el FIFA 2007 con muchos parches biggrin2 blush)
Y honestamente, no sé si con "reinstalar el SO" se borren mis programas instalados....  noclue confused

Pero bueno, ahí esta el problema planteado. En realidad no es algo que me quite el sueño... Digo, no pude instalar ninguna versión de messenger y pues utilizo meebo o ebuddy... No pude instalar el Nod32, y pues instale el Avast... En fin, como dije, no es un problema que me quite el sueño, pero es como la piedrita en el zapato... Por más que intento no pensar en ello y no darle importancia, sé que esta ahí presente y que no lo he podido resolver...


Ah, por cierto... Estas son las características de mi Sistema:


-Laptop marca Toshiba modelo SATELLITE A135
-Windows Vista Home Basic 32 bits (licencia Om)
-Procesador Intel Centrino Duo 1.73 Ghz.
-Memoria Ram 1526 Mb
-Mainbord: Toshiba
-Tarjeta de Video: Intel(R) Graphics Media Accelerator Driver

Bueno, eso es todo... Espero respuestas... encontremos qué es lo que esta ocasionando este cáncer...

Por cierto, si sugieren (como también creo que alguna vez Nekro sugirió), que cambiase de SO a Linux, bueno, tengo también que contarles que apenas probe (en versión Pendrive) Fedora y me resulta un tanto "complicado" habituarme a la interfase... Digo, seguiré probando a ver que tal pero... de momento no es algo que me haya atraído lo suficiente para dejar Windows... además tengo que admitirlo... Soy más músico, poeta y loco que programador, entonces no creo que le pueda exprimir todo el potencial....

Todo esto último sólo fue una nota informativa, algo así como un pequeño parentesis jajaja.

Saludos
Silent's Heroe


« Última modificación: 16 de Enero, 2010, 00:11:57 por Silent's Heroe » En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #1 en: 16 de Enero, 2010, 11:33:50 »

Hola Silent's Heroe, muy completa la descripción, pero falta algo esencial: ¿te da algún error en particular? ¿Un mensaje? ¿Algo? Como diría House: "¿Qué nos dicen los síntomas?"

No mencionas nada al respecto, así que asumo que quizá los errores no son visibles. Revisa el Visor de Eventos de Windows para ver los errores que estén relacionados.

Pienso que quizá los parches que hayan metido mano a los archivos de sistema habrán tenido algo que ver, pero no hay manera (práctica) de estar seguros.

Saludos
Arwing
En línea

Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Re: Problema para instalar archivos .msi
« Respuesta #2 en: 16 de Enero, 2010, 15:40:19 »

Jajajaja... Hola amigo, tienes toda la razón, me faltó lo esencial.... Creo que maté a la abuela.... LOL LOL LOL Bueno, transcribo el mensaje de error (lo da a la mitad de la instalación)

"El programa de instalación se ha encontrado con un error inesperado mientras instalaba este paquete. Podría ser una señal de que hay un problema  con el paquete. El código de error es 2203"


Me he puesto a googlear varias veces en busca de referencia al error y lo único que he encontrado es que el error hace referencia a una directiva de seguridad, por lo que entendía, significa que (ojo) "NO TENGO LOS PERMISOS NECESARIOS PARA INSTALAR EL PROGRAMA".... pero se supone que soy el dueño de la Lap y cuando la inicié, "heredé" todos los permisos....

He intentado de todo, ejecutar el programa como administrador, ejecutarlo con otra configuración desde el asistente de compatibilidad, reinstalar windows installer, hasta deshabilitar el UAC (User Access Control), pero nada funciona.

Qué cosa más rara no?.... Soy el dueño de la casa pero no puedo entrar al baño.... LOL LOL

Además encontré el siguiente post donde alguien pudo resolver el problema al instalar archivos .msi, (aunque con otro código de error), pero desconozco realmente qué es lo que hizo... hace referencia a la solución que encontró pero honestamente no entendí...

http://ealmeida.blogspot.com/2007/10/instalando-archivos-msi-en-windows.html

Y bueno, no creo que sean los parches la causa de esto... Si no mal recuerdo, creo que ya había posteado un mensaje donde exponía que no podía instalar el messenger, y eso fue desde que compré la Lap...

Oye, por cierto, que gustazo me da saber que también ves Dr. House.... qué tipo no???

SilentsHeroe
« Última modificación: 16 de Enero, 2010, 15:52:42 por Silent's Heroe » En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #3 en: 16 de Enero, 2010, 23:55:00 »

Me parece que te encontré Heroe: http://social.technet.microsoft.com/Forums/es-ES/wcvistaes/thread/1049fce4-16fc-4e2c-8b17-f528c3f3267f

Sí, recuerdo que no podías instalar el mensajero, ¿has estado sufriendo desde entonces? Qué tortura.

Según lo leído, ambos, el enlace que mencionas y el de TechNet te recomiendan lo mismo. Al parecer, por alguna razón ejecutarlo desde el entorno gráfico no permite que le lleguen los permisos y por eso falla. Ambos te recomiendan abrir el símbolo del sistema/consola/cmd/línea de comandos con privilegios de administrador, moverte a la carpeta donde tienes el archivo .msi y ejecutarlo. En TechNet recomiendan además ejecutarlo en modo silencioso.

Citar
Oye, por cierto, que gustazo me da saber que también ves Dr. House.... qué tipo no???

Sí, es una de mis series favoritas, aunque no he tenido oportunidad de ver la quinta temporada. Es un personaje muy peculiar, de hecho está basado en Sherlock Holmes.

Saludos
Arwing
En línea

Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Re: Problema para instalar archivos .msi
« Respuesta #4 en: 17 de Enero, 2010, 01:21:56 »

Citar



 blush blush blush jejejeje... Si, creo que lo has hecho... whistling whistling

Citar
Sí, recuerdo que no podías instalar el mensajero, ¿has estado sufriendo desde entonces? Qué tortura.

 ranting aggressive No te burles... matlingua jajajaja. Pues sufrir, sufrir, lo que se llama sufrir, pues no, porque también para mi desgracia, como ya les había comentado en algún post. Estuve más de un año sin internet en casa, entonces no tenía motivo para "extrañar" el mensajero en la lap, dado que no lo necesitaba. Entonces, un problema me resolvió el otro... Además me conseguí novia y todo termino por que se me olvidara.... LOL LOL LOL... Aunque la novia ya me dejó... Ya tengo otra vez internet... y por consecuencia... ahora si extraño el mensajero.... LOL LOL LOL LOL LOL

Regresando al problema...

Citar
abrir el símbolo del sistema/consola/cmd/línea de comandos con privilegios de administrador, moverte a la carpeta donde tienes el archivo .msi y ejecutarlo.

Wuau... no entendí muy bien... Por lo que entiendo tengo que abrir el símbolo de sistema y moverme a la carpeta donde tengo el archivo .msi... Porque eso de /consola/cmd/línea de comandos con privilegios de administrador... simplemente no sé que onda...

Cuando habro el símbolo de sistema como administrador (Click en inicio, todos los programas, accesorios, doy click derecho sobre símbolo de sistema y en el menú desplegable que aparece selecciono "ejecutar como administrador"... lo de la consola como que no entendí... cry blush

Probaré haciéndolo como te indico haber si lo estoy haciendo correctamente, y si no, espero que me corrijas, de cualquier forma te platico cómo me fue...


Citar
Oye, por cierto, que gustazo me da saber que también ves Dr. House.... qué tipo no???

Sí, es una de mis series favoritas, aunque no he tenido oportunidad de ver la quinta temporada. Es un personaje muy peculiar, de hecho está basado en Sherlock Holmes.


NO inventes, en verdad....Huh Bueno, para mí, de hecho es mi serie favorita... y también por problemas de $, así como me deshize del internet, tuve que deshacerme de la televisión por cable entonces ya no pude ver tampoco la quinta temporada, y también pa mi desgracia, al igual que con el internet, ahora que contraté el "Triple Play" de la compañía de cable local, resulta que ya no ofrecen en su paquete básico el canal de Universal y pues ya no puedo ver la sexta temporada... Aunque me estoy dando ahora sí con más lana, el lujo de comprar cada mes una temporada del Dr. House, además de que de vez en cuando la veo online en algunas páginas que ofrecen el servicio... clap yahoo yahoo

Y no sólo esta basado en Holmes, sino también en Sócrates... De hecho, si te gusta la serie y la forma de razonamiento que utiliza House te recomiendo que compres el libro "La Filosofía de House: Todos Mienten. De William Irwin" Cuesta alrededor de 170. Yo lo conseguí en Ghandi y es genial... Esta es la sinopsis

Citar
¿EXAGERAMOS CON ESO DE PORTARNOS BIEN?
¿REALMENTE SOMOS SOLO UNOS ANIMALES EVOLUCIONADOS, EGOÍSTAS, QUE VAGAMOS POR LA TIERRA Y NUESTRA EXISTENCIA NO TIENE NINGÚN SIGNIFICADO?
¿SERIA MEJOR LEER MENOS Y VER MAS TELEVISIÓN?
¿ES HOUSE UN MAESTRO DE LA FILOSOFÍA OCCIDENTAL O SIMPLEMENTE UN PERFECTO SANGRÓN?

PODRÍA DECIRSE QUE EL DOCTOR GREGORY HOUSE ES EL ANTIHÉROE MÁS DESAFIANTE Y COMPLEJO EN TODA LA HISTORIA DE LA TELEVISIÓN, PERO ¿EXISTE ALGO MÁS QUE MATERIA GRIS Y EGO PARA ESTE GENIO ENGREÍDO?

ESTA OBRA ANALIZA LA SERIE DR. HOUSE CON EL FIN DE EXPLICAR SUS BASES FILOSÓFICAS Y LA CONDUCTA EXTRAVAGANTE DE SU PROTAGONISTA GRUÑÓN.

SE TRATA DE UN PERSONAJE COMPUESTO POR PEDAZOS DE SHERLOCK HOMES, SÓCRATES, NIETZSCHE Y LA RETÓRICA TAOÍSTA, Y NO ES TAN RETORCIDO COMO UNO CREERÍA.

LA FILOSOFÍA DE HOUSE ABARCA DESDE ARISTÓTELES HASTA EL ZEN. FASCINARÁ A LOS DEVOTOS DE ESTE GENIO MISÁNTROPO Y EQUIPO EN EL HOSPITAL PRINCETON-PLAINSBORO

Existe otro libro basado en House que se llama "Filosofía para la vida de House", lo escribe un español pero no lo he podido conseguir...

Bueno, ahora sí, ciao y gracias, te platico que tal me fue...

Saludos
Silent's Heroe
En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #5 en: 17 de Enero, 2010, 01:57:17 »

Lo de la consola, utilizas el comando cd para cambiar de directorio. Así, si tú estás en C:\ y quieres dirigirte al directorio ubicado en C:\folder, ejecutas el comando:

Código:
cd folder

Aquí estás usando rutas relativas, es decir, entrarás al directorio 'folder' relativo a tu directorio actual ('C:\'), y después de ejecutar el comando, tu directorio actual será 'C:\folder'

También puedes usar rutas absolutas, es decir, indicar la ruta completa del directorio:

Código:
cd C:\folder

y después de ejecutar dicho comando ya estarás en el directorio especificado. Intenta colocarte en el directorio usando la ruta absoluta, y ya en el directorio sólo escribe el nombre del archivo .msi y presiona la tecla Enter.

Igual y escribir la ruta completa incluyendo el archivo .msi debería funcionar. Si tienes más dudas con los comandos dime para ayudarte.



He visto el primer libro que mencionas, pero no me he animado a comprarlo porque lo vi muy ligerito. Pero por lo que dices ya me dio más curiosidad por leerlo, la próxima vez que lo vea me lo compro para ver qué tal.

El segundo ni siquiera me suena. ¿Lo has buscado en librerías online?

Saludos
Arwing
En línea

Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Re: Problema para instalar archivos .msi
« Respuesta #6 en: 19 de Enero, 2010, 23:04:18 »

Hola Arw... px qué crees, que ya intenté lo que me recomiendas (ejecutar el archivo desde la consola de comando) pero simplemente no me deja instalarlo, continúa mandándome el mismo error 2203 ranting ranting

Quise instalarlo desde el modo a prueba de errores pero, pues obvio tampoco puedo porque no corre el windows installer... No No

Otra cosa que me sorprendió es que intenté instalar el Ad-Aware (que descargué desde el sitio oficial) y me botó un nuevo error (te mostraría la imagen pero por desgracia olvidé mi contraseña de mi cuenta ftp que un día me creaste.... blush)

El caso es que al intentar instalar dicho programa me comenta que también va a instalar Microsoft Visual C++ Runtime 9.0 (incluye ATL y MFC) Service Pack 1...

Acepto la instalación e inmediatamente después se detiene por el mismo error 2203. Y me manda otro aviso con el mensaje:

"No se pudo instalar Microsoft Visual C++ Runtime 9.0 Service Pack1. Utilice Windows Update para instalar manualmente esta actualización en su sistema."

Ello me llevó a pensar que quiza el problema con los .msi era que no tenía instalado Microsoft Visual C++. Revisé y si lo tengo instalado, tengo la versión 2005 Redistributable, pero me sorprendió darme cuenta que sólo pesa 558kb. Fui a la carperta de archivos de programa donde supuestamente esta instalado y sólo pesa 14.5 kb y tiene un sólo archivo llamado asp.tlb...

O sea... qué onda?Huh?

Descargué el Visual C++ 2005 y el 2008 para instalarlos pensando que quiza tengo mal instalado el Visual en la compu, y me di cuenta que el tamaño de cada uno de los archivos ejecutables es de entre 2 y 3 megas... Entonces como puedo tener yo el paquete instalado con sólo 558kb?Huh

Bueno bueno.... Pues intenté instalar primero  el Visual C++ 2005 y no me dejó. Igual, error 2203. Luego intenté con el 2008 y fue lo mismo, sólo que ahora, después de darme el típico error 2203 y cerrar dicha pantalla, me bota un aviso de Error de Windows diciendo:

Citar
"Setup.exe dejó de funcionar.
Ocurrió un error durante la instalación y se creó un informe con información útil sobre el problema detectado.

Detalles de Informe de Error:

Descripción:
  Microsoft Visual C++ 2008 Redistributable Package ha tenido problemas durante la instalación. El programa de instalación no se completó correctamente.

Firma con problemas:
  Nombre del evento de problema:   VisualStudio8Setup
  Firma del problema 01:   11867
  Firma del problema 02:   [VERSION]_[LAB]_[PFLAVOR]
  Firma del problema 03:   MSI
  Firma del problema 04:   INST
  Firma del problema 05:   F
  Firma del problema 06:   -
  Firma del problema 07:   -
  Firma del problema 08:   1603
  Firma del problema 09:   -
  Firma del problema 10:   -
  Versión del sistema operativo:   6.0.6000.2.0.0.768. 2
  Id. de configuración regional:   2058

Información adicional del problema:
  LCID:   3082
[/b]


En fín, que ya no sé que hacer... Así estoy hasta este momento... Ojala puedas darme otro comentario

Oye, por cierto, en caso de que intentara reinstalar el SO con el disco que me dieron cuando compre la Lap... Se borrarían todos los programas que tengo actualmente instalados?

Me recomiendas actualizar mi sistema a Windows 7 o crees que eso tendría problemas de compatibilidad con el Hardware?


Saludos
Silent's Heroe
« Última modificación: 19 de Enero, 2010, 23:18:36 por Silent's Heroe » En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #7 en: 22 de Enero, 2010, 01:43:21 »

Bien, nuevos síntomas. Revisando un poco en los foros de Ad-Aware encontré un error ligeramente parecido: http://www.lavasoftsupport.com/index.php?showtopic=24993

Lo interesante es la respuesta del usuario maurash, ya que la solución que propone es sencilla y parece un tanto "lógica". Tengo la sensación de que podría funcionar.

Básicamente, el problema de que no se instale el Visual C++ Runtime es que el servicio de Windows Installer no se encuentra activo. Por lo que hay que ir a Inicio >> Ejecutar >> escribimos 'services.msc' y Enter >> y buscamos el servicio 'Windows Installer' y cambiamos su tipo de inicio a uno diferente de 'Desactivado'.

Es una solución que también aparece en una página para la resolución de problemas comunes con Windows Installer: http://support.microsoft.com/?scid=kb%3Ben-us%3B555175&x=5&y=14. Y en caso de no funcionar podemos probar los demás métodos, a pesar de que el artículo fue revisado por última vez en el 2006 y que no especifica que funcione para Vista (aunque Vista salió en 2006), pero ya sabemos que Microsoft arrastra algunas cosas por lo que vale la pena intentar.

Creo que lo de la diferencia de tamaño del Visual C++ Runtime lo dejaremos de lado por ahora, ya que solucionando lo del Windows Installer se solucionaría lo del Visual C++.

Si aún así sigues obteniendo errores, por favor revisa si en el Visor de Eventos aparece algo más relacionado al problema. Creo que no has revisado ahí o por lo menos no lo has comentado.

Citar
Oye, por cierto, en caso de que intentara reinstalar el SO con el disco que me dieron cuando compre la Lap... Se borrarían todos los programas que tengo actualmente instalados?

Es algo que no puedo saber porque depende de cada fabricante cómo hayan diseñado los discos y las opciones que estos ofrecen, y también dependerá si se trata de discos de rescate o de instalación. Opino que es más probable que los discos te quieran formatear la computadora y dejarla en el estado como la obtuviste, pero es pura suposición. Creo que si quieres estar seguro lo mejor sería que te contactes con el fabricante para preguntar. De igual manera revisa los discos, a lo mejor puedes encontrar el manual y ver si menciona algo al respecto.

Citar
Me recomiendas actualizar mi sistema a Windows 7 o crees que eso tendría problemas de compatibilidad con el Hardware?

La verdad no sabría decirte. Yo supondría que no habría problemas de hardware, ya que los problemas de ese tipo que he visto ocurren más bien por tratar de instalar sistemas operativos relativamente antiguos (Windows XP por ejemplo) en laptops nuevas.

¿Por qué no tratas de instalar W7 junto a Vista en otra partición para ver cómo se comporta? Hasta donde yo sé debería ser posible y así no perderías tu instalación en Vista.

Saludos
Arwing
En línea

Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Re: Problema para instalar archivos .msi
« Respuesta #8 en: 28 de Enero, 2010, 21:09:51 »

Hola mi estimadísimo Arw... Px qué crees??? Que intenté lo que comentan en los links que me pasaste pero namás no funcionó...  Pero px entre tanta información me vino a la mente que si el famoso error 2203 era por una cuestión de permisos, tons quería decir que no se configuró correctamente mi cuenta de administrador desde el principio, así que se me ocurrió abrir otra cuenta de administrador y resulta que... Px bueno, desde ahí si puedo instalar varios archivos que en mi cuenta de administrador original no podía... Por ejemplo pude instalar el Nod32, y el Flash C4... No sé, crees que sea porque no se configuró bien al inicio mi cuenta de administrador... Huh

Porque no entiendo como desde otra cuenta de administrador si puedo instalar archivos que no podía... No sé, se me hace muy raro... Pero bueno, se me ocurrió que si el problema es la configuración de mi cuenta de administrador original, entonces al abrir otra cuenta ya no tendría dichas broncas... O sea, dejar de trabajar con la cuenta original (JAGT) y comenzar a trabajar con otra... Al respecto las preguntas son:

1.-  ¿Todos los archivos que instale en mi cuenta de administrador original (JAGT), también pueden ser ejecutados desde todas las demás cuentas?...

2.- ¿Si borro el perfil de administrador (JAGT) se borran los archivos que instalé con esa cuenta? O sea, tendría que volver a reinstalar todo en la nueva cuenta de administrador???

3.- ¿Si borro el perfil original (jagt) no se "desconfigura" nada?... O sea, que lo borre y que produzca algún conflicto con el sistema???

4.- O crees que lo mejor sería conservar la cuenta antigua de administrador pero trabajar ya con la nueva cuenta que te comento....Huh?

Bueno, pues así el caso, espero tu consejo.

Saludos
Silent's Heroe
En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #9 en: 29 de Enero, 2010, 22:10:16 »

Vaya, qué cosas Huh, resultó ser más simple el asunto. Pues si ese es el caso, lo que te recomendaría que hicieras sería que con la nueva cuenta de Administrador que creaste, te asegures de asignar todos los permisos para tu cuenta de usuario original. Como mencionas, quizá desde un inicio tu cuenta original no tenía correctamente establecidos los permisos.

Saludos
Arwing
En línea

Silent's Heroe
General
*****
Desconectado Desconectado

Mensajes: 395


Tu presente y futuro son el espejo de tu pasado


Re: Problema para instalar archivos .msi
« Respuesta #10 en: 02 de Febrero, 2010, 23:05:38 »

Hola amigo Arw. Bueno, pues no quería hacerlo pero aquí me tienes de nuevo blush. Intenté por mi cuenta hallar la forma de volver a asignar todos los permisos para mi cuenta de administrador pero simplemente no supe qué onda... confused Huh

Te platico. Revisé un poco y según yo la forma para reestablecer los permisos es a través de la opción de directivas de grupo (gpedit.msc) pero en mi versión de Windows Vista (Home Basic) esa opción no existe.

Intenté a través de la consola de comandos acceder a mmc.exe (raíz de consola) y desde ahí ver si podía existir alguna opción para reasignar cuentas de usuario pero esta demasiado complicado para mi manejar todas las opciones que tiene.

Me fui entonces por la fácil. Desde la nueva cuenta de administrador, cambiar el tipo de cuenta de la cuenta original, a Usuario, y después volverla a cambiar a administrador para ver si se reasignaban los permisos pero no funcionó. No No

Entonces intenté otra opción, desde la nueva cuenta de Administrador, ingresar a Mi PC, dar click derecho sobre Disco Duro c:, Propiedades, Seguridad y desde ahí modificar los permisos a la cuenta de administrador original, pero NO ME MANEJA POR SEPARADO LOS PERMISOS PARA LAS CUENTAS DE ADMINISTRADOR. En otras palabras, se supone que las dos cuentas de administrador que tengo, poseen los mismos permisos... noclue

Estoy un poco liado con esto, es por ello que decidí volver a molestarte con este asunto... blush biggrin2

Digo, lo de menos es dejar mi antigua cuenta de administrador como usuario estandar y cuando quiera agregar un programa, pues agregarlo desde la otra cuenta de administrador (que ya sería la única) pero pues eso resulta un tanto "bochornoso", dado que tendría que estar constantemente cambiando de usuario... (bueno, no tanto porque tampoco instalo muchos programas verdad....Huh? jajaja).

Oye, un caso curioso, bueno, al menos para mí. Con mi cuenta de administrador (JAGT) como Usuario estandar, traté de instalar un programa... Obvio, me pide ingresar la contraseña del administrador del equipo (la nueva cuenta de administrador que tengo), la ingreso y se supone que ya comienza a instalar el archivo (dado que lo hice como administrador, por lo menos con los permisos de éste), pero de nueva cuenta, a la mitad me bota el error 2203.... No se supone que, como Usuario Estandar, al intentar instalar un programa, como se utilizan los permisos del Administrador del equipo (nueva cuenta que tengo) el programa se debería instalar sin problema...

Me explico... Con mi cuenta de administrador original (JAGT) no podía instalar algunas cosas. Con la nueva cuenta, si puedo. Cambio la cuenta JAGT a Usuario estándar. Trato de instalar algo... Lo hago ingresando contraseña ya de la única cuenta de administrador que tiene el equipo... Se supone que desde esta cuenta si puedo instalar los programas... pero no, sigue sin dejarme instalar el programa. Aun cuando se supone que lo esta haciendo "con" y "desde" los permisos de la "cuenta de administrador que funciona"... Para instalar el programa tengo que salir de la cuenta JAGT (de usuario estándar) e ingresar a la otra cuenta (administrador) y desde ahí instalar el programa, que por supuesto, si se instala.... Qué cosas no...Huh aggressive

Espero me haya explicado, y ojala puedas ayudarme para "reasignar" o "reiniciar" los permisos de mi cuenta de administrador... Gracias

Saludos
Silent's Heroe
En línea

Si la pasión, si la locura no pasaran alguna vez por las almas… ¿Qué valdría la vida?

Lo pasado ha huido, lo que esperas está ausente, pero el presente es tuyo...k esperas para aprovecharlo
Arwing
General de Generales
*****
Desconectado Desconectado

Mensajes: 2,191



WWW
Re: Problema para instalar archivos .msi
« Respuesta #11 en: 04 de Febrero, 2010, 23:45:54 »

Hola Heroe, la verdad es que no sé qué ocurra con tu cuenta original. Algo que se me ocurre es que quizá a pesar de ser cuenta administrativa no se encuentre en el mismo grupo que la cuenta administrativa recién creada.

Leyendo un poco me entero que las cuentas de administrador 'normales' en Windows Vista no es el nivel de administrador más alto que puede haber, ya que dentro de Vista hay una cuenta de administrador oculta que, a lo que he entendido, tiene más privilegios que las cuentas administrativas normales. En tu caso encuadra un poco pero no creo que sea eso, dado que para activar esta cuenta administrativa oculta requieres seguir unos pasos específicos pero no has mencionado nada de eso.

También otra cosa que podrías intentar sería deshabilitar las medidas de seguridad introducidas en Vista, el User Account Control, ya que así los administradores normales entrarían con los permisos completos. O por lo menos esa es la teoría, ya que así lo indica la documentación: http://technet.microsoft.com/en-us/library/cc709628(WS.10).aspx. Haciendo eso básicamente reviertes el sistema de usuarios al modelo usado en Windows XP. Pero no sé qué tan cómodo te sientas haciendo eso, ya que hay cierto riesgo al usar el sistema todo el tiempo como administrador, pero como siempre, depende de qué tan cauto seas usando el sistema y de tus hábitos de usuario.

Fuera de eso, sería hacer lo que tú dices, mantener ambas cuentas, y usar la que funciona para instalar los programas problemáticos.

Ojalá tuviera más experiencia con Vista, pero la verdad es que dudo tener más de dos horas de uso acumuladas en todo el tiempo que Vista ha existido Lengua

Saludos
Arwing
En línea

shinxuac
Forastero
*
Desconectado Desconectado

Mensajes: 1



Re: Problema para instalar archivos .msi
« Respuesta #12 en: 08 de Abril, 2010, 02:25:38 »

Hola a todos, también tenía este problema (a mi me marco Error 1305), creía que mi instalador se habían dañado, volví a descargarlo y lo mismo, hasta que en la noche en mis sueños se iluminó la solución  rolleyes, se me ocurrio mover la carpeta donde se encontraba el instalador hacia el escritorio, luego ejecute el instalador como administrador (clic derecho al archivo, luego seleccionar: ejecutar como administrador) y funcionó de maravilla  victory, no marco ningún error.
Luego me pregunte porque a fuerza la tenía que mover al escritorio, creo que fué porque la carpeta de instaladores la tenia protegida (solo en mi usuario podía ingresar), también pudo ser que mis instaladores se encontraban en otra unidad de Disco Duro.

Espero que te sirva esta solución, hay nos cuentas si te funciona a ti.  cool2

Saludos.
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2007, Simple Machines LLC XHTML 1.0 válido! CSS válido!
Página creada en 0.737 segundos con 18 queries.